Главная » Error » Encountered error while trying to install package

Encountered error while trying to install package

Я хочу установить пакет gensim python через pip install gensim.

Но возникает эта ошибка, и я не знаю, что мне делать, чтобы решить ее.

  running build_ext
      building 'gensim.models.word2vec_inner' extension
      error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> gensim

note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure.


Если вам не удалось установить плагины,
вы можете скачать его из других репозиториев, например, из этого: репозиторий зависит от версии python и системы.

например: для windows 11(x64) и python 3.10 вы должны взять этот файл: gensim-4.1.2-cp310-cp310-win_amd64.whl

Error while installing packages

Я использую Ubuntu 12.04. Я столкнулся с ошибкой при установке любого пакета с помощью apt-get. Я пробовал шаги, приведенные на различных форумах, но не смог решить проблему. Например, если я устанавливаю kcachegrind, код ошибки следующий:

[Я заменил http:// на http// только для того, чтобы избежать ссылок при размещении вопроса. Поэтому, пожалуйста, читайте http// как http:// в сегментах кода].

Попробуйте выполнить следующие команды,

sudo dpkg -P mysql-client-5.1
sudo apt-get install -f

 

В ошибке написано что для компиляции пакета нужно установить Microsoft C++ Build Tools версии 14.2 или выше, а также приведена ссылка где их можно скачать: https://visualstudio.microsoft.com/visual-cpp-build-tools/.

 

Hi,
pip install sentencepiece fails,
This is the log I get:

pip install sentencepiece
7.4.0
Collecting sentencepiece
Using cached https://files.pythonhosted.org/packages/fd/45/6d0eb609d5cd81df094aab71a867b2ab6b315ffd592e78fb94a625c4d6aa/sentencepiece-0.1.3.tar.gz
ERROR: Complete output from command python setup.py egg_info:
ERROR: /bin/sh: 1: pkg-config: not found
Failed to find sentencepiece pkgconfig
—————————————-
ERROR: Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-install-463tj_x8/sentencepiece/

Same here, only happens on Python 3.7.4 for me, works on Python 3.6. Observed on Ubuntu 16.04.4

Collecting sentencepiece
  Downloading https://files.pythonhosted.org/packages/fd/45/6d0eb609d5cd81df094aab71a867b2ab6b315ffd592e78fb94a625c4d6aa/sentencepiece-0.1.3.tar.gz (498kB)
     |████████████████████████████████| 501kB 41.1MB/s
    ERROR: Complete output from command python setup.py egg_info:
    ERROR: Package sentencepiece was not found in the pkg-config search path.
    Perhaps you should add the directory containing `sentencepiece.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'sentencepiece' found
    Failed to find sentencepiece pkgconfig
    ----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-cqmezxh3/sentencepiece/

 

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Пока оценок нет)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован.

Adblock
detector