Главная » Error » Error can t resolve vue

Error can t resolve vue

Я все еще практикую использование webpack2 с vue js и babel, но столкнулся с этой ошибкой. Я не знаю, чего не хватает.

ERROR in ./src/main.js 
Module not found: Error: Can't resolve.

Я решил свою проблему, так как кажется, что я не могу удалить ответ. я отредактирую, как я решаю проблему.

изменить эту часть

import AppComponent from './app/index.vue'

в

import AppComponent from '../app/index.vue'

Это видео, по которому ты пытаешься научиться, есть хороший пример, как делать не нужно.
Во-первых, он использует вторую версию Vue, а во-вторых, очень много косяков. Я тоже пытался у него учиться, голову сломал.

выглядит как-то, что вы можете получить, когда не запускаете npm install

можете ли вы проверить, существует ли папка vue в C:\xampp\htdocs\project\public\Vue\node_modules?

Здравствуйте, выходит такая ошибка: Failed to compile.

Пытался переустановить (установить) sas-loader, но после появляются новые ошибки. Ошибка с sass-loader: Failed to compile.

Прочесть документацию sass-loader’а, и сделать то что там написано. Ошибка не в библиотеке Vue, а в твоем конфиге вебпака.

Потому что его нужно использовать в проекте UI элемента Vue2 + (не рекомендуется заходить на официальный сайт Element UI)<style lang="scss">.

но я буду использоватьcnpm install node-sass -D Получилось! ! ! 

Я хочу использовать следующий способ доступа к каталогу моего приложения с использованием простого шаблона webpack-simple @ / components /, но для меня он просто генерирует ошибку

module not found error can’t resolve ‘@/components/ error

из прочитанного мной есть кое-что, что мне нужно настроить в конфигурации webpack, чтобы эта работа работала, но я не могу найти, что это такое, может ли кто-нибудь помочь, пожалуйста?

Теперь в моем импорте я просто пишу что-то вроде

    import myModule from '@/fileInSrcFolder';

где @ – это папка src внутри корневой папки.

Добавление @vue/babel-preset-app в качестве одного из devDependencies должно решить проблему.

Я решаю эту проблему после запуска этой команды. npm install @vue/babel-preset-app --save-dev

Я запустил следующую команду npm install -D babel-loader @babel/core @babel/preset-env webpack

После этого я запускаю npm install vue-style-loader

Наконец, я запускаю следующую команду npm i autoprefixer, и она сработала для меня.

Ваш код:

  import AppComponent from './app/index.vue'

Преобразуем в:

import AppComponent from '../app/ index.vue'

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Пока оценок нет)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован.

Adblock
detector